Jelle Vegter

02/17/2023, 7:11 AM
Hi all! Since yesterday my flows have been failing with the error message: Submission failed. KeyError: “No class found for dispatch key ‘azure-container-instance-job’ in registry for type ‘Block’.“. I suspect this error is popping up due to the recent updates but am unsure where it came from. I was using docker image prefecthq/prefect:2-python3.9, which updated recently, so I since updated my project to Prefect 2.8.1 and now run the flow on a docker image using prefecthq/prefect:2.8.1-python3.9. When I inspect the AzureContainerInstanceJob from my own laptop (the flows run in Azure Container Instances) I can fetch the block without issue. ” AzureContainerInstanceJob(type=‘container-instance-job’, env={}, labels={}, name=None, command=None, aci_credentials=AzureContainerInstanceCredentials(client_id=‘xxxxxxx’, tenant_id=‘xxxxx’, …) ” Any have a sense of direction for me? Thanks!

Ryan Peden

02/17/2023, 9:14 AM
You would get this error if the
isn't installed on the machine/container where you agent is running. Could that have happened somehow when you updated your project?
I see someone else ran just into the same error with 2.8.1 and ECS; it might be worth rolling your agent back to 2.8.0 until we're able to investigate this further.

Jelle Vegter

02/17/2023, 10:29 AM
I indeed rolled back (2.7.8) and it works again
Will patiently wait until updating version! Thanks

James Gatter

02/17/2023, 2:28 PM
Was having the same problem with ecs-task so I rolled back to 2.7.12 and that worked.


02/17/2023, 4:16 PM
2.82 is being released right now with the fix
❤️ 1