Hi, for some reason my deployments disappeared tog...
# prefect-community
n
Hi, for some reason my deployments disappeared together with my blocks. I tried to reconfigure the GCP storage (which was already configured) but now I get
Copy code
(finance-lGLYToYy-py3.9) ➜  finance git:(master) ✗ prefect storage create
No storage types are available. 
(finance-lGLYToYy-py3.9) ➜  finance git:(master) ✗ prefect version
Version:             2.0b10
API version:         0.7.0
Python version:      3.9.10
Git commit:          e71ef86c
Any idea what changed?
1
a
we removed default storage in favor of explicit file systems set on Deployments - check the latest #announcements for more details
👀 1
n
I don’t understand why, but deployments and cloud runs fail with this exception
Copy code
Traceback (most recent call last):
  File "/media/noam/Storage/projects/finance_manager/flows/scrapers/flow.py", line 108, in <module>
    asyncio.get_event_loop().run_until_complete(scrape(**flow_param))
  File "/home/noam/.pyenv/versions/3.9.1/lib/python3.9/asyncio/base_events.py", line 642, in run_until_complete
    return future.result()
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/prefect/client.py", line 107, in with_injected_client
    return await fn(*args, **kwargs)
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/prefect/engine.py", line 176, in create_then_begin_flow_run
    flow_run = await client.create_flow_run(
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/prefect/client.py", line 604, in create_flow_run
    response = await <http://self._client.post|self._client.post>("/flow_runs/", json=flow_run_create_json)
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/httpx/_client.py", line 1842, in post
    return await self.request(
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/httpx/_client.py", line 1527, in request
    return await self.send(request, auth=auth, follow_redirects=follow_redirects)
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/prefect/client.py", line 280, in send
    response.raise_for_status()
  File "/home/noam/.cache/pypoetry/virtualenvs/finance-ypnOChiK-py3.9/lib/python3.9/site-packages/prefect/client.py", line 226, in raise_for_status
    raise PrefectHTTPStatusError.from_httpx_error(exc) from exc.__cause__
prefect.exceptions.PrefectHTTPStatusError: Client error '422 Unprocessable Entity' for url '<https://api-beta.prefect.io/api/accounts/f4d683cc-9f7c-4b3c-898e-4fd651bebdae/workspaces/b212a541-cda0-4742-af7d-5e85c344805c/flow_runs/>'
Response: {'exception_message': 'Invalid request received.', 'exception_detail': [{'loc': ['body', 'flow_runner'], 'msg': 'extra fields not permitted', 'type': 'value_error.extra'}], 'request_body': {'name': 'successful-slug', 'flow_id': 'ccf6df07-85ef-4723-a66d-4f5ff188ed8d', 'deployment_id': None, 'flow_version': 'd91a0e050a75164cbe9638ddbe55ea46', 'parameters': {'card_suffix': '5094', 'start_date': '01/02/2021', 'future_months_to_scrape': 24}, 'idempotency_key': None, 'context': {}, 'empirical_policy': {'max_retries': 0, 'retry_delay_seconds': 0.0}, 'tags': [], 'parent_task_run_id': None, 'flow_runner': None, 'state': {'type': 'PENDING', 'name': 'Pending', 'message': None, 'data': None, 'state_details': {'flow_run_id': None, 'task_run_id': None, 'child_flow_run_id': None, 'scheduled_time': None, 'cache_key': None, 'cache_expiration': None}}}}
For more information check: <https://httpstatuses.com/422>
Everything worked fine a couple of days ago…
a
You need to upgrade to the latest Prefect version, which is 2.0b12 as of now, and you would need to recreate deployments using the infrastructure module instead of flow runners sorry for not being more transparent about communicating those changes, but we have to change some things still before GA release on Wednesday check out this post to get more clarification: https://discourse.prefect.io/t/prefect-2-0b12-removes-flow-runners-in-favor-of-more-flexible-infrastructure-blocks/1232
n
Using poetry and version does not exists?
Because finance depends on prefect (2.0b12) which doesn't match any versions, version solving failed.
I’ve reverted to
2.0b11
, should I simply wait for Wednesday when things become more stabilized? It is super frustrating to debug issues that stem from beta releases.
a
this user has an issue but then said: "it works now" https://github.com/PrefectHQ/prefect/issues/6053
can you try again?
n
poetry update worked
a
thanks for the update! 🙌
158 Views