https://prefect.io logo
#prefect-server
Title
# prefect-server
s

Sam Pibworth

07/20/2022, 2:17 PM
Hello, got a problem with Prefect server UI not being able to connect to core. The toml file has the line
apollo_url = "http:/<ip of azure vm>:4200/graphql"
. Any help would be much apperciated!
k

Kevin Kho

07/20/2022, 2:29 PM
On the VM when you start, you need:
Copy code
[server]
  
  [server.ui]
    
    apollo_url = "<http://YOUR_MACHINES_PUBLIC_IP:4200/graphql>"
And on local machine that connects to VM:
Copy code
[server]
endpoint = "YOUR_MACHINES_PUBLIC_IP:4200/graphql"
And if using
prefect server start
, maybe you need the
--expose
flag?
s

Sam Pibworth

07/20/2022, 2:38 PM
Thanks Kevin, I've done all those things already. Still not working unfortunately
Nevermind, it's decided to work now. Thanks for your help!
k

Kevin Kho

07/20/2022, 4:16 PM
Lol. Nice!
9 Views