https://prefect.io logo
#prefect-server
Title
# prefect-server
s

Sandeep Dass

07/19/2022, 5:51 PM
Question about prefect server graphql endpoint. Getting the below error. Any ideas as to why
k

Kevin Kho

07/19/2022, 5:56 PM
Are you running on localhost or on a different machine?
s

Sandeep Dass

07/19/2022, 5:57 PM
localhost.
k

Kevin Kho

07/19/2022, 5:58 PM
Do you see the API container running healthy?
s

Sandeep Dass

07/19/2022, 6:01 PM
sudo docker ps [sudo] sdass@catl0slas11168's password: CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 39d54bc7d9f0 prefecthq/ui:core-1.0.0 "/docker-entrypoint.…" About a minute ago Up About a minute (healthy) 80/tcp, 0.0.0.0:5003->8080/tcp tmp_ui_1 f7f58f4e43d1 prefecthq/apollo:core-1.0.0 "tini -g -- bash -c …" About a minute ago Up About a minute (healthy) 0.0.0.0:4200->4200/tcp tmp_apollo_1 5153135cf09c prefecthq/server:core-1.0.0 "tini -g -- python s…" About a minute ago Up About a minute tmp_towel_1 e8dec14a403a prefecthq/server:core-1.0.0 "tini -g -- bash -c …" About a minute ago Up About a minute (healthy) 127.0.0.1:4201->4201/tcp tmp_graphql_1 19e4f5f1bc58 hasura/graphql-engine:v2.1.1 "graphql-engine serve" About a minute ago Up About a minute (healthy) 127.0.0.1:3000->3000/tcp tmp_hasura_1 8ee219be3bc9 postgres:11 "docker-entrypoint.s…" About a minute ago Up About a minute (healthy) 127.0.0.1:5432->5432/tcp tmp_postgres_1
startup log.
n

nicholas

07/19/2022, 7:12 PM
@Sandeep Dass one quick test you can do to determine if your endpoint is being exposed properly is to visit localhost:4200/graphql in your browser. If it’s exposed properly you should see a graphql playground by default
s

Sandeep Dass

07/19/2022, 7:30 PM
i am able to reach it from the outside. localhost is a VM in this case.
k

Kevin Kho

07/19/2022, 7:35 PM
Was the first UI image in the same VM or from outside?
s

Sandeep Dass

07/19/2022, 7:42 PM
the vm is "catl0slas11168" i get the first UI image when i do this "http://catl0slas11168:5003/getting-started". Prefect server is running on "catl0slas11168". So graphql endpoint should be "localhost:4200/graphql"? i am not able to set this. but this works, http://catl0slas11168:4200/graphql Hope this makes sense?
a

Anna Geller

07/19/2022, 7:56 PM
moving to thread
n

nicholas

07/19/2022, 8:58 PM
Ok perfect, so the answer is that you need to provide a reference to the VM and not localhost; you can do this by setting your
apollo_url
in your server’s config.toml to the address of your VM
Take a look at this documentation, which will walk you through the process
s

Sandeep Dass

07/20/2022, 11:30 AM
Thank you all. Much appreciated.
🙌 1
3 Views