https://prefect.io logo
#prefect-community
Title
# prefect-community
a

Amol Shirke

07/11/2022, 5:38 PM
Hello, I have prefect server behind load balancer interface. Deployment are created successfully with CLI but those don't. Show up on UI. Here is how I am running prefect orion. Prefect version: 2.0b8 $prefect orion start --host 0.0.0.0 --port 8065 $ set config: prefect config set http://0.0.0.0:8065/apiapi To access that host address is like http://hostname:some_random_portport UI is getting loaded but deployment is blank. CLI shows it. I tried setting up config to hostname with random port as well but didn't work. Any thoughts? Thanks
z

Zanie

07/11/2022, 5:54 PM
You need to set the
PREFECT_ORION_UI_API_URL
on the machine that runs
prefect orion start
. It should be the same as the API URL that a client would need to access the API.
a

Amol Shirke

07/11/2022, 6:00 PM
I am setting this variable to http://0.0.0.0:8066/api
z

Zanie

07/11/2022, 7:03 PM
From your client machine that you are attempting to access the UI at, if you navigate to the URL can you reach the API?
a

Amol Shirke

07/11/2022, 7:10 PM
It doesn't give 500 error. Response is something like {details:not found}
z

Zanie

07/11/2022, 7:21 PM
How about
<http://0.0.0.0:8066/api/docs>
?
It seems likely that the API is not reachable at that URL from your client.
a

Amol Shirke

07/11/2022, 7:36 PM
I cannot use :8066 its not accessible need to use interface port I.e. http://hostname:43518
z

Zanie

07/11/2022, 7:40 PM
You should set the
PREFECT_ORION_UI_API_URL
to that then
3 Views