https://prefect.io logo
Title
j

James Zhang

11/14/2022, 10:30 PM
hi guys, i’m trying to get the UI running in our own k8s cluster, but it seems that the UI just can’t get the URL right… • if I don’t set
PREFECT_ORION_UI_API_URL
, there will be error saying it can’t communicate with
127.0.0.1/api
• if I set
PREFECT_ORION_UI_API_URL
e.g.
company.domain/api
, the error is gone, but now the UI make bizarre request with URL
<https://company.domain/company.domain/api/xxx>
which returns 405 errors that I see in browser network log… so is there anything I could do? I’m on version 2.6.7
1
r

Ryan Peden

11/14/2022, 10:34 PM
I believe I've seen this happen when I've left the protocol out of the value I set for
PREFECT_ORION_UI_API_URL
. If you are setting it to
company.domain/api
, try setting it to
<https://company.domain/api>
instead.
🙌 1
j

James Zhang

11/14/2022, 10:37 PM
amazing, it helped! thanks alot!
r

Ryan Peden

11/14/2022, 10:38 PM
You're very welcome! 😄