https://prefect.io logo
#prefect-ui
Title
# prefect-ui
d

Dev Dua

04/05/2022, 4:55 AM
Hi all! I’m using Prefect 2.0b and I am running it on my dev machine.. I want to access the Orion UI from another machine but it shows me no data because it’s making API calls to localhost:4200 instead of the API URL I set (using
PREFECT_API_URL
) to
0.0.0.0:4200/api
Is there another way to accomplish this?
a

Anna Geller

04/05/2022, 10:20 AM
This environment variable is correct. You would need to set it in your profile config to connect to a different API:
Copy code
prefect config set PREFECT_API_URL=<http://42.42.42.42:4200/api>
if this doesn't work for you, you can use Cloud 2.0 instead (free tier, no credit card required)
d

Dev Dua

04/05/2022, 5:01 PM
Sadly I can’t exercise this option, I need to self-host If that variable is correct, why isn’t it being used correctly on the web app?
a

Anna Geller

04/05/2022, 6:07 PM
that's the question 😄 you'd need to troubleshoot then. I'd recommend checking all components and taking it step by step - maybe start doing everything only from that single machine with a simple hello-world flow and then move to a remote agent pointing to this self-hosted API. This docs page is a great start to understand profiles and Prefect 2.0 settings https://orion-docs.prefect.io/concepts/settings
d

Dev Dua

04/08/2022, 8:33 AM
👀 1
a

Anna Geller

04/08/2022, 10:18 AM
Thanks a lot. Michael responded there
15 Views