Hi all, my company is testing prefect and I am hav...
# prefect-community
b
Hi all, my company is testing prefect and I am having trouble installing a kubernetes agent, which I suspect is because of the company proxy. When I try to install the agent the logs say that it is being registered, but then eventually I get an SSL error.
requests.exceptions.SSLError: HTTPSConnectionPool(host='<http://api.prefect.io|api.prefect.io>', port=443): Max retries exceeded with url: / (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1091)')))
Is there a way to provide proxy credentials when starting the agent? I've tried using the --env flag to supply proxy information. Or is there something similar to a --verify=false that I can set?
a
Hi @Bennett Lambert - SSL errors are hard to troubleshoot remotely. You could try setting this environment variable:
Copy code
export CURL_CA_BUNDLE=""
This Discourse topic discusses a similar issue and has some suggestions you may try https://discourse.prefect.io/t/how-to-disable-the-ssl-verification-when-setting-up-a-pr[…]e-verify-failed-unable-to-get-local-issuer-certificate/597
The CURL_CA_BUNDLE and PYTHONHTTPSVERIFY may not work on Windows though
b
ok thanks for the help!
I'm on Windows and setting CURL_CA_BUNDLE='', PYTHONHTTPSVERIFY='false' and the HTTP_PROXY and HTTPS_PROXY environment variables did the trick
a
Thanks so much for verifying that! 🙌
438 Views