Will Goldstein

08/18/2020, 9:07 PM
I'm trying to get started with the kubernetes agent locally (and just
prefect server start
for the scheduler) it keeps firing up pods that try to connect to localhost:4200 for the graphql endpoint and failing because they can't access
from inside a pod. Is there a way to specify the endpoint the pods should be trying to connect to (e.g. to `kubernetes.docker.internal`instead)?

Jim Crist-Harif

08/18/2020, 9:20 PM
Hi Will, you can configure the api address used by the agent when deploying the agent via the
option on
prefect agent start
prefect agent install
. Note that the pods will need access to the server api, so you may need to do additional networking config (not sure) to ensure network access between k8s and docker.

Will Goldstein

08/18/2020, 9:20 PM
Thanks so much!
👍 1