David Kuda

12/04/2020, 4:03 PM
Hey everyone! I have been testing Prefect for two weeks now. We soon want to test it on some real projects! 🙂 I am trying to accomplish some things, but I don’t succeed yet … There is for example this issue which prevents me from advancing really: How do I change the port for database? This is how I do it now: I run
prefect server start --postgres-port=5435 --ui-port=8081
-> that works. And now I want to change it so the
handles it. So in my home directory/.prefect (~/.prefect) I have the file `config.toml`with following content:
Copy code
		host = "localhost"
		port = 5435
		host_port = 5435
		url = "<https://localhost:5435>"
		connection_url = "<postgresql://prefect:test-password@localhost:5435/prefect_server>"
		name = "prefect_server"
		username = "prefect" 
		password= "test-password"
		volume_path = "/Users/david/.prefect/pg_data"
I have tried many things with this config.toml file … but nothing has worked. When I try
prefect server start
, I receive an error:
ERROR: for t_postgres_1  Cannot start service postgres: Ports are not available: listen tcp bind: address already in use
. What’s going wrong? When I write something wrong, say I use a colon instead of an equal sign,
prefect server start
returns yet another error, which is good. I have examined the possible config options with `prefect config`; I did not see any other setting for database / postgres. I am following the docs very precisely, I even did the YouTube tutorials which were hosted by Laura, which were all great. Best Regards from Berlin!


12/04/2020, 4:06 PM
Hi! It looks like you’re counting on indentation to indicate
is nested within
doesn’t actually support that!
Take a look at the example file and try saying
instead of just
🤙 1
👍 1
❤️ 2

David Kuda

12/04/2020, 4:10 PM
Wonderful!!! That has worked! Thank you so much!
I have been actually trying so hard to fix that haha 🙂 Thanks for the quick and reliable support!