Hello Prefect Community, I have an issue while ins...
# prefect-community
v
Hello Prefect Community, I have an issue while installing the latest version of Orion i.e. "Prefect 2.0a13". I see the error while deploying the ray[default]>=1.9. I am on Python 3.7.6 and running this on the Linux platform. Does anyone have a similar issue? Thanks
a
Afaik, Orion works best on Python 3.9 and higher because it uses a lot of latest and gratest Python async features etc. Can you try with 3.9?
v
I could definitely but most of our codebase is on Python 3.7 so we would have to upgrade before we can use Orion. Just wondering if there is no plan to support Python 3.7?
a
Officially we do support 3.7 😄 the setup.py says:
Copy code
python_requires=">=3.7",
But personally, I would try to upgrade if possible So maybe it's just an issue with your installation. I'll try to reproduce on 3.7
I couldn't reproduce in a conda env: can you try new fresh virtual environment?
v
Sure, let me try
I tried though I am getting the same error
a
Could it be because you're downloading the packages from Nexus instead of Pypi?
Can you try using Pypi instead to check if that works?
v
Tried again but not from the nexus but directly with PyPi though same issue
a
what's your OS? e.g. if you're running it on Ubuntu <= 18.04 it could be that the default Python 3.6 version somehow gets used instead on a newer one
v
Hey Anna, thanks for coming back. I am working on the RedHat 6 rather Ubuntu
k
This seems like Ray is the one requiring Python above 3.7. I think Ray should me made as an installation extra. Will check
Ray will eventually be moved to an installation extra
z
Hm we install Ray on 3.7 in CI on Linux machines and have no issues.
It looks like your PyPI registry is way behind on Ray versions
v
Hey @Zanie, not sure if I completely got you. But I was using the internal nexus repository before, but I tried changing from nexus to PyPI and still had a similar issue, so I believe it might be something completely different
z
What’s the output of
pip debug
?
v
Let me try and run again
pip debug output
z
And
pip index versions ray
v
pip index versions ray
I don't see 1.9.2
z
Yep you are missing lots of the newer versions. Here’s the output on a simple linux container with 3.7
Copy code
❯ docker run --platform linux/amd64 -t python:3.7 pip index versions ray
WARNING: pip index is currently an experimental command. It may be removed/changed in a future release without prior warning.
ray (1.11.0)
Available versions: 1.11.0, 1.10.0, 1.9.2, 1.9.1, 1.9.0, 1.8.0, 1.7.0, 1.6.0, 1.5.2, 1.5.1, 1.5.0, 1.4.1, 1.4.0, 1.3.0, 1.2.0, 1.1.0, 1.0.1.post1, 1.0.1, 1.0.0, 0.8.7, 0.8.6, 0.8.5, 0.8.4, 0.8.3, 0.8.2, 0.8.1, 0.8.0, 0.7.7, 0.7.6, 0.7.5, 0.7.4, 0.7.3, 0.7.2, 0.7.1, 0.7.0, 0.6.6, 0.6.5, 0.6.4, 0.6.3, 0.6.2, 0.6.1, 0.6.0
WARNING: You are using pip version 21.2.4; however, version 22.0.4 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
v
Also, if I run the pip debug --verbose | grep "cp37-cp37m-manylinux"
z
Try
pip index versions ray -v -v
— it’ll give you a lot of output. We’ll want to see if the versions are around but don’t have the requisite tags.
v
Looks like it is getting skipped all the new version
z
I’d suggest opening an issue on Ray’s github repo with some of this information
This is kind of beyond our purview 🙂
v
So, from the pip debug --verbose, I could see we have "cp37-cp37m-manylinux2010_x86_64" but not 2014
z
Ah yeah so it seems like your linux version is too old
v
Cool, I would do that but just wondering if the Ray is really required dependency on the Prefect
z
No it’s not, we’ll be dropping it from the actual requirements
v
Wonderful, thanks that would be great as I don't know if Ray would even support the older version of Linux 😉
z
You can do
pip install --no-dependencies prefect
v
Wonderful, I would sure do that, thanks for that, I wasn't aware
z
Then
Copy code
pip install "aiofiles>=0.7.0" "aiosqlite>=0.17.0" "alembic>=1.7.5" "anyio>=3.2.1" "asgi-lifespan>=1.0" "asyncpg>=0.23" "azure-storage-blob>=12.9.0" "boto3>=1.20.0" "click>=7.1.2" "cloudpickle>=1.5" "coolname>=1.0.4" "croniter>=1.0.1" "cryptography>=36.0.1" "distributed>=2021.8.0" "docker>=4.0" "fastapi>=0.66" "fsspec>=2021.7.0" "google-cloud-storage>=2.1.0" "httpx>=0.18" "kubernetes>=17.17.0" "pendulum>=2.1.2" "pydantic>=1.8.2" "python-slugify>=5.0" "pytz>=2021.1" "pyyaml>=5.1b1" "rich>=10.0" "sqlalchemy[asyncio]>=1.4.20" "toml>=0.10.0" "typer>=0.4.0" "typing_extensions>=3.10.0.1" "uvicorn>=0.14.0"
v
Thanks, it worked and I can pip install the prefect dependencies manually for now except for Ray
z
Yep!
v
👍
Thanks that was really helpful
z
Np, sorry it wouldn’t just install properly 😄