Hi, I’m trying to run `prefect server start` and r...
# prefect-server
Hi, I’m trying to run
prefect server start
and running into an error:
{"internal":"could not connect to server: Connection refused\n\tIs the server running on host \"postgres\" ( and accepting\n\tTCP/IP connections on port 5432?\n","path":"$","error":"connection error","code":"postgres-error"}
There’s a lot more to the error I can supply. I’ve done
prefect backend server
before trying to start the server
Hi Hugo, could you provide a bit more of the error?
here is a good chunk of it. thanks!
Hmmm is there enough space allocated for Postgres?
Copy code
postgres_1  | The files belonging to this database system will be owned by user "postgres".
postgres_1  | This user must also own the server process.
postgres_1  | 
postgres_1  | The database cluster will be initialized with locale "en_US.utf8".
postgres_1  | The default database encoding has accordingly been set to "UTF8".
postgres_1  | The default text search configuration will be set to "english".
postgres_1  | 
postgres_1  | Data page checksums are disabled.
postgres_1  | 
postgres_1  | fixing permissions on existing directory /var/lib/postgresql/data ... ok
postgres_1  | initdb: could not create directory "/var/lib/postgresql/data/pg_wal": No space left on device
postgres_1  | initdb: removing contents of data directory "/var/lib/postgresql/data"
t_postgres_1 exited with code
how would I change that? I did check my system memory and it is not full
This may be an issue with the amount of space allocated to Docker. Perhaps try running
docker system prune --volumes
to reclaim space?
thank you! didn’t know that they would be related. It’s fixed
🚀 1
Happy to help!