# prefect-server


08/06/2021, 8:04 AM
sorry to keep posting here but im still having problems getting this to run on a VM. i have tried both inside a venv and outside. Googling doesnt seem to help. Prefect installs with no errors but running
prefect server start
keeps giving me this error. Is there somewere i can just get a copy of the docker-compose file? I’ve tried this on two VMs now
Copy code
        Can't find a suitable configuration file in this directory or any
        parent. Are you in the right directory?

        Supported filenames: docker-compose.yml, docker-compose.yaml
i had a look in the directory mentioned in the traceback for the docker-compose.yml and it is there, so I’m not sure why it isn’t being recognised
Copy code
Traceback (most recent call last):
  File "******/venv/lib/python3.8/site-packages/prefect/cli/", line 608, in start
  File "/usr/lib/python3.8/", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['docker-compose', 'pull']' returned non-zero exit status 1.
update, I have edited the cwd within which seems to have resolved that problem, but now i am faced with an issue with the docker deamon. I feel like there must be something obvious I’m missing

Kevin Kho

08/06/2021, 1:39 PM
If you have errors with the Docker daemon, are you able to do
docker run hello-world
to make sure it works? There can be permission things related to that. If this succeeds, the
prefect server start
should work. Maybe you also need to install
in additional to Docker? The
is here


08/09/2021, 8:52 AM
it was an issu with permissions. the way i got around it in the end (hopefully this might help others) was to add the user to the docker group
👍 1