I’m having trouble running prefect server on my lo...
# prefect-server
I’m having trouble running prefect server on my local machine (MBP with intel processor). I believe it’s run successfully before, but today I’m getting this error message:
Error response from daemon: Ports are not available: listen tcp bind: address already in use
. I’ve tried restarting the computer, reinstalling docker desktop, and making a fresh conda environment with a fresh installation of prefect, but the error persists. When I run
lsof -i:5432
, I get no output. Any ideas for next troubleshooting steps?
Hey Paul, outside of Prefect do you run postgres on your local machine normally?
For example I installed postgres using homebrew and it normally runs on startup of my machine in the background.
Copy code
~ brew services
Name       Status  User       Plist
postgresql started jakekaplan /Users/jakekaplan/Library/LaunchAgents/homebrew.mxcl.postgresql.plist
And I get your same error if I do not stop postgres since it defaults to
No, it doesn’t appear to be running:
Copy code
$ brew services list
Name       Status  User Plist
emacs      stopped      
postgresql stopped
But that made me realize I can specify a different port for postgres; running
prefect server start --postgres-port 5433
👍 1
I'm sorry I couldn't help you find the initial issue but I'm glad you're able to find a workaround!