Anyone have issues with Git storage and a bunch of...
# prefect-server
Anyone have issues with Git storage and a bunch of gobbedigook being appended to the repo? This is a new one, I’m fiarly sure that we haven’t updated anything on registration on our end: I checked by importing the same version of our helper library:
Copy code
It’s unexpected to see that
That’s weird. First time I’ve seen it. How do you define your storage here?
This is part of a larger class…this is the relevant snippet:
Copy code = Git(
it’s hardcoded in what repo_host to use, which makes it stranger
edited because I am wondering if that is a gitlab ID for my company
For this is the format Git storage uses. Anything before the @ is the secret. Maybe check the secret value? = Git(repo="my/repo", flow_path="/flows/", repo_host="<|>")
then you dont need
for repo host
ah crap ok I see what happened thank you.
👍 1
yep, gotta rotate that that a recent update to the Git storage? We didn’t have this issue before
That file hasnt been edited since Oct 8 for 0.15.7
But doesnt seem like that was changed
Seems like it’s aways been like that
Weird - so on further investigation, it must be something in my Gitlab config or something…I made that update and I get that there is no repo at the location given..but what’s weird is I can run git clone with that location locally and clone it
Do you self host your git repo?
I am wondering if there might be some authentication needed? We use this utility class to clone the repo if you want to test pulling directly
I wouldn’t think so only because we were registering/running flows before and this is a new problem with one specific repo. I just updated my helper library with the
removed from the hostname and all worked fine.
the gitlab access token secret has worked in the past
Ah ok. Are you good now?
No haha I’ll follow up tomorrow if I figure anything out
I guess what would help is if there’s anyway I can see what git command is being run to pull the repo from Git storage
This appears to be an issue with Dulwich v 0.20.30. I use poetry to manage my python packages and noticed that that version was used in the builds that were failing. I forced it back to version 0.20.26 and it worked fine. I am not sure if this should be considered a bug on Prefect or not, but I’m happy to put something in…I’m using v 0.15.10
Let me check the requirements and setup and see if we need to pin
sure sounds good
thank you!
s - please let me know if anything needs to be added…as it is a simple change I did not add a file in to /changes but am happy to do so if required.
You don’t want to be in our changelog? 😅
Ah I guess Michael said fixing compatibility would be better
hahaha fine by me, I just want my flows to work 😄
would’ve been smallest contribution ever probably