Nathan Walker

    Nathan Walker

    1 year ago
    Hey folks, I just upgraded from 0.14.12 to 0.14.19 and now localhost:8080 brings me to Cloud login. I double-checked
    prefect backend server
    was set and I've also cleared localhost and Prefect cookies to no avail. Any thoughts on how to fix this?
    nicholas

    nicholas

    1 year ago
    Hi @Nathan Walker - this looks like an issue with the UI image version - we're fixing that and I'll ask you to re-pull the image shortly 🙂
    Nathan Walker

    Nathan Walker

    1 year ago
    Thank you!
    @nicholas - false alarm. I rolled back to 0.14.12 and it still happened there. I tried on a different browser to the same effect. I eventually nuked all my browser cache and the UI worked properly. I re-upgraded to 0.14.19 and it's working great.
    nicholas

    nicholas

    1 year ago
    Hm that's super odd - we did stop caching some of those settings somewhat recently so that's potentially a cause; thanks for the follow up!
    Let me know if you see any other issues
    Nathan Walker

    Nathan Walker

    1 year ago
    Can do!
    Related: I'm trying to run 0.14.19 using the docker-compose.yml generated from
    prefect server config
    and it's defaulting to Cloud backend/UI. Is there an environment variable I can set for the Server backend? Changing the images to 0.14.18 fixes the issue.
    nicholas

    nicholas

    1 year ago
    Aha! That's the issue I thought you were facing to begin with. Let me get those image retags out
    Nathan Walker

    Nathan Walker

    1 year ago
    Woo!
    Also: If I want to do some UI development is there a way to know which UI tag goes with which Core/Server tags? (e.g., can I use UI '2021-05-05' with Core '0.14.12' or just with Core '0.14.15'+?)
    nicholas

    nicholas

    1 year ago
    Typically the UI should work with all versions of Core but only the version of Server that corresponds to that release (for API reasons)
    Nathan Walker

    Nathan Walker

    1 year ago
    Excellent
    nicholas

    nicholas

    1 year ago
    Or I should say the UI is always backwards compatible with Core, not necessarily forwards-compatible, for reasons
    Ok @Nathan Walker - would you mind pulling the 0.14.19 image again?
    Nathan Walker

    Nathan Walker

    1 year ago
    @nicholas OK, the Cloud issue is taken care of, but now it just gets to an empty dashboard (green "database" icon) and hangs at empty.
    nicholas

    nicholas

    1 year ago
    Could you do a hard refresh and share the JS developer console?
    Nathan Walker

    Nathan Walker

    1 year ago
    One error for app~d0ae3f07.bf8a418c.js: index.js:71 Uncaught (in promise) Error: passed invalid or empty tenant object at l.setDefaultTenant (index.js:71) at vuex.esm.js:844 at vuex.esm.js:466 at Array.forEach (<anonymous>) at vuex.esm.js:465 at l._withCommit (vuex.esm.js:624) at l.commit (vuex.esm.js:464) at l.commit (vuex.esm.js:409) at tenantNavGuard.js:12 at u (runtime.js:63)
    nicholas

    nicholas

    1 year ago
    Hm is this a brand new server startup? Do you have an existing tenant?
    Nathan Walker

    Nathan Walker

    1 year ago
    I'm not tenant-savvy. I don't have any other containers running and just did
    docker-compose up --force-recreate
    nicholas

    nicholas

    1 year ago
    Ah ok, my guess is that you need to create a tenant by running
    prefect server create-tenant --name <<something>> --slug <<something>>
    Normally the
    prefect server start
    command will take care of this for you
    Nathan Walker

    Nathan Walker

    1 year ago
    Oh, right - it works with
    prefect server start
    but not when I try to run it from prefect server config's docker-compose.yml. Which container should build the tenant?
    nicholas

    nicholas

    1 year ago
    The tenant needs to be inserted into the database, so the
    create-tenant
    command calls the
    create_tenant
    graphql route 🙂
    Nathan Walker

    Nathan Walker

    1 year ago
    Heyooo, it works. Thank you!
    nicholas

    nicholas

    1 year ago
    Perfect! 🙂
    Nathan Walker

    Nathan Walker

    1 year ago
    I'm running into the same Cloud-default issue when I swap out the UI image from prefecthq/ui:core-0.14.19 to my locally-built image based on the most recent UI GitHub clone. Will the changes be reflected in the UI GitHub or can you point me in the right direction on fixing this?
    nicholas

    nicholas

    1 year ago
    Sorry @Nathan Walker - did you re-pull the 0.14.19 image and ran into the same issue? Since master represents the bleeding edge I'm not surprised that didn't work
    Also would you mind pasting the JSON (feel free to obfuscate any sensitive data) you get back when visiting
    <http://yourserverendpoint/settings.json>
    ?
    Nathan Walker

    Nathan Walker

    1 year ago
    When I re-pulled core-0.14.19 everything worked great. When I re-pulled from UI master on GitHub and built from there, I still ran into the issue -- looking at the merge pull request log, though, it makes sense because I'm not seeing any activity in the last 2 days (do you have a different repo that "core" UI images are built from or is there a branch I can checkout?).
    nicholas

    nicholas

    1 year ago
    Ah I see - yes Core builds its own UI images based on pinned versions of the UI; in this case it's pinning to a slightly older release of the UI for compatibility
    The fix for this issue isn't out yet, which is why Core is pinning to a version before the bug happened
    Nathan Walker

    Nathan Walker

    1 year ago
    Ohhhhhh ok that makes sense. FWIW, with core-0.14.19 w/ latest UI master I get:
    settings.json
    is just
    {"server_url": "<http://localhost:4200/graphql>"}
    nicholas

    nicholas

    1 year ago
    Ah ok that's what I'd expect, just wanted to be sure