Thread
#prefect-ui
    o

    Ondrej Melichar

    1 year ago
    Hi, whats the correct way to setup https access to the UI?
    Kevin Kho

    Kevin Kho

    1 year ago
    Hey @Ondrej Melichar, are you talking about Prefect server? In 0.15.5, you need to use the
    --expose
    flag when setting up Prefect server to allow outside connections, and then open port 443
    Yiyang Tsui

    Yiyang Tsui

    1 year ago
    Thanks, I upgraded from 0.15.1 to 0.15.5 on a VM server today, then the browser just show connection refused. I tried to tweak the config file and change environment variables PREFECT_SERVER__BASE_URL, UI_HOST_IP ..etc. no luck… until I checked in here trying to ask..the answer is right here.
    o

    Ondrej Melichar

    1 year ago
    @Kevin Kho yep, i mean the prefect server. If i use the
    expose
    flag, where will I get/set the certificate?
    Kevin Kho

    Kevin Kho

    1 year ago
    Sorry I’m confused, what certificate do you need? You just need to add the flag when you start server. This is the relevant PR