Hi! The UI doesn't seem to agree with CRON (or me,...
# prefect-ui
f
Hi! The UI doesn't seem to agree with CRON (or me, or the code-based schedules). I've managed to create a task with a schedule
*/5 * * */2 *
which the UI correctly parses as
Every 5 minutes, every 2 months
. However, I can't set that schedule in the UI, is that by design or an unintentional discrepancy between the two? The same input under Settings -> Schedule -> Advanced -> Cron just tells me "Invalid Input" :(
a
@Fredrik Hilding what is the intention behind this schedule? Do you want to run your flow every 5 minutes every hour every day in February, but in March you want no flow runs, and then in April again every 5 minutes every single day?
f
actually, it was only the */5 or */10 etc on the minutes I was after, i.e. running something at 00, 05, 10, 15 of every hour. The Month stuff was just to see if it accepted it everywhere too, I can't come up with any reasonable excuse for that one 🙂
a
Then you need just */5 * * * *
f
I think so too, but the UI does not
But it can correctly interpret it when I've set it via Python
a
thanks for reporting that! I will open an issue so that UI folks can have a look at it. In the meantime, if you need to set this schedule via UI, you could do:
🙌 1
@Marvin open “Setting interval schedule via Cron doesn’t work from the UI” in UI
f
Thanks @Anna Geller
a
@Marvin open “Setting interval schedule via Cron doesn’t work from the UI”
j
Try again - @Marvin open “Setting interval schedule via Cron doesn’t work from the UI"
🤔 1