Thread
#prefect-contributors
    s

    Shaun Cutts

    2 years ago
    I’m not sure if its environment setup issue; I have:
    - name: HASURA_API_URL
         value: <http://prefect-server-hasura.prefect-server.svc.cluster.local:3000/v1alpha/graphql>
        - name: PREFECT_API_URL
         value: <http://prefect-server-graphql.prefect-server.svc.cluster.local:4201/graphql/>
        - name: PREFECT_API_HEALTH_URL
         value: <http://prefect-server-graphql.prefect-server.svc.cluster.local:4201/health>
        - name: GRAPHQL_SERVICE_HOST
         value: <http://prefect-server-graphql.prefect-server.svc.cluster.local>
        - name: GRAPHQL_SERVICE_PORT
         value: "4201"
    which I think are correct:
    prefect-server-graphql        ClusterIP  172.20.137.57  <none>    4201/TCP  38m
       prefect-server-hasura        ClusterIP  172.20.185.76  <none>    3000/TCP  38m
    Do I also need PREFECT_SERVER__* settings here? Any other debugging info? chart code is in https://github.com/PrefectHQ/server/pull/57 @Chris White @Jeremiah — any thoughts?
    Chris White

    Chris White

    2 years ago
    Hey @Shaun Cutts - thanks for the legwork here! It’ll be a little while before either of us has a chance to review properly but we’ll let you know when we are able to
    s

    Shaun Cutts

    2 years ago
    Thanks — so its still very much WIP … perhaps no need to “review properly” in the full sense of the phrase. 🙂 .. but I assume that I’ve either mis-wired, or that I’ve forgotten some configuration, and that is causing the apollo problem — if you spot what is wrong there that would be great.
    @Chris White @Jeremiah I realize you guys are busy…. I was motivated to work on this all though the last weekend, because I need to use it not too long from now. I’m currently stuck on the problem with apollo, My hypothesis is that it would be easy to get apollo to “tell me what is wrong”, but unfortunately I know nothing about it. If either one of you has a few minutes to look things over and give me a tip wrt to the apollo container, I would be really grateful.
    Chris White

    Chris White

    2 years ago
    👍 also @josh might have some insight as well
    s

    Shaun Cutts

    2 years ago
    Thank you! 😃
    j

    josh

    2 years ago
    I’ll take a deeper look into it today, I was able to get the same error you saw but I wasn’t able to diagnose why it was occurring at a glance
    s

    Shaun Cutts

    2 years ago
    Thanks @josh! — given that I can hit graphql from apollo container, but apollo doesn’t seem to try, I wonder if apollo is (e.g.) ignoring “host” setting and just using localhost/4201. That’s why I was suspicious of the “local” setting. [If this is a correct diagnosis, of course we could put apollo in same pod as graphql, but in future perhaps might want to scale them separately?]