Thread
#prefect-ui
    Rajvir Jhawar

    Rajvir Jhawar

    1 month ago
    A couple of UI issues here using Prefect 2.0.3:1. Click a flow run --> if it has a long parameter it goes off the page (image1) 2. Not sure how to reproduce this one, the profile menu sometimes likes to move from where it supposed to be (image2) 3. On the work queue page if you upcoming flow runs that have tags that are too long to display it is suppose to show a "+1". On some of the flows this indicator gets cut off (image3) 4. Why do the "Flow Version" and "Tags" not appear on the flow run right away? As far as I can tell you have to wait until the flow run goes into terminating states to see it change. Can we just get them to show up right away? (image4) 5. If you have multiple flow run the tags order changes for some reason. Create two flows each with a tag of "name", "type" --> the second flow run always swaps the order of this tags for some reason.
    Khuyen Tran

    Khuyen Tran

    1 month ago
    @Jenny
    nicholas

    nicholas

    1 month ago
    This is a bug in the UI and will be fixed in the next release - thanks for raising @Rajvir Jhawar!
    Jenny

    Jenny

    1 month ago
    Hi @Rajvir Jhawar - thanks for the feedback here! I was OOO on vacation last week so apologies for the late comments from me. 1 - That's a bug and we'll look into it and get a fix out asap. 2. This is a known issue and we're working on a fix. 3 & 5. I couldn't replicate 3 but I think adding some sort of basic sort should help with both that and 5 - I've opened a ticket in our internal repo to tackle that. 4a. The lack of tags is a bug and should be fixed asap. 4b. - I want to look into the flow version question and will get back to you!
    And for flow versions: Flow versions are user-provided strings that are supposed to help with managing code changes, especially for flows that you operationalize yourself (i.e., flows and flow runs that aren't generated from a deployment). For example, maybe it's a machine name, git commit sha, or just a string "testing". Because they are user-provided, they only get set after the run has begun -- the scheduler can't set the version on the run.
    Rajvir Jhawar

    Rajvir Jhawar

    1 month ago
    Ah ok got it thanks for the for followup!