Thread
#prefect-community
    Tom Thurstan

    Tom Thurstan

    2 months ago
    Hi Prefect team! Since upgrading to Prefect-2.0b12 the module flow_runners no longer exists. Where are we supposed to import e.g. SubprocessFlowRunner from? Have tried to find it in the package but no luck. Thanks!
    Riccardo Tesselli

    Riccardo Tesselli

    2 months ago
    I’ve faced a similar issue but with
    KubernetesFlowRunner
    , I’ve solved taking a look into the
    prefect.infrastructure
    package
    Tom Thurstan

    Tom Thurstan

    2 months ago
    Ah! Thank you. So I guess you replaced
    KubernetesFlowRunner
    with
    KubernetesJob
    ?
    Riccardo Tesselli

    Riccardo Tesselli

    2 months ago
    exactly, notice that now the
    Deployment
    object requires a instance of
    Infrastructure
    Tom Thurstan

    Tom Thurstan

    2 months ago
    ah yes I see, thanks. Did you read this somewhere? Or are you just figuring it out from the source code?
    Riccardo Tesselli

    Riccardo Tesselli

    2 months ago
    I’ve checked a couple of hours ago if the documentation was updated but still no luck, so I went directly looking at the code
    Tom Thurstan

    Tom Thurstan

    2 months ago
    Yeah that’s what I thought. I was hoping you were going to say you had found new docs somewhere haha! Even the docstrings in the code itself seem to be out of date
    Riccardo Tesselli

    Riccardo Tesselli

    2 months ago
    I think it’s better to wait a couple of days for the public release