Thread
#prefect-community
    wonsun Jeong

    wonsun Jeong

    2 months ago
    Hi all~ I want to know that how to change the prefect's default server database! (using prefect 1.0) There's method "Running Prefect with a pre-existing postgres database" in prefect docs. But can i change the
    server.database.connection_url
    or
    server.database.host
    to connecting information for MySQL database, not postgres?
    Anna Geller

    Anna Geller

    2 months ago
    No, currently only Postgres is supported as a Server backend
    wonsun Jeong

    wonsun Jeong

    2 months ago
    oh... I see. thank you for your fast reply💙
    Galler.. Same problem, sorry to ask twice! I set the Secret at Cloud. (like below image) And I imported the modules related to Secret in the python file where flow is defined and wrote the code as follows.
    team_db = Secret('my_strow').get()
    But i got the error message like this.
    Traceback (most recent call last):
      File "/home/.prefect/flow.py", line 199, in <module>
        team_db = Secret('my_strow').get()
      File "/home/enviorments/test/lib/python3.10/site-packages/prefect/client/secrets.py", line 170, in get
        raise ValueError(
    ValueError: Local Secret "my_strow" was not found.
    I think that I'm not enough understanding about secret on cloud and local secret. Also weird things, last week i already run this flow code that same method. What am i missing?? 😟
    The only difference from when the flow running well is I changed the content of 'my_strow' in the UI.
    @Anna Geller
    Anna Geller

    Anna Geller

    2 months ago
    try this:
    export PREFECT__CLOUD__USE_LOCAL_SECRETS=false
    wonsun Jeong

    wonsun Jeong

    1 month ago
    Hi Anna, as you said above, I used the export~ method to call and use the secret stored in the cloud, but when I turn off the computer or run flow in some cases,
    Value error  : Local Secret was not found.
    appears. I want to fundamentally solve this problem, could you please tell me what is wrong? The order in which I execute the prefect (1.0) flow is usually as follows.1. virtual enviorment activate 2. prefect backend cloud 3. prefect server start 4. prefect agent local start -p <entered specific path> 5. export PREFECT__CLOUD__USE_LOCAL_SECRETS=false Is there something wrong? I hope this error doesn't happen again.. 😞 @Anna Geller
    Anna Geller

    Anna Geller

    1 month ago
    this is only valid if you want to use Cloud:
    export PREFECT__CLOUD__USE_LOCAL_SECRETS=false
    for Server, you only have local Secrets so you should use:
    export PREFECT__CLOUD__USE_LOCAL_SECRETS=true
    this will clarify more https://discourse.prefect.io/t/how-to-set-secrets-e-g-github-access-token-on-server/70
    wonsun Jeong

    wonsun Jeong

    1 month ago
    Humm.. I use the secret stored in the cloud as
    export PREFECT__CLOUD__USE_LOCAL_SECRETS=false
    but sometimes it works well and sometimes it doesn't... There is no secret set in local.
    Anna Geller

    Anna Geller

    1 month ago
    check this Discourse thread, it has a detailed explanation
    wonsun Jeong

    wonsun Jeong

    1 month ago
    Will do. Appreciate it