Joshua Greenhalgh

    Joshua Greenhalgh

    2 months ago
    I thought I would have a play with 2.0 today - tried running the code here -> https://orion-docs.prefect.io/tutorials/first-steps/ - get following error?
    ValueError: the greenlet library is required to use this function. No module named 'greenlet'
    Any ideas?
    Running on M1 - installed with poetry...
    Khuyen Tran

    Khuyen Tran

    2 months ago
    I assume your run
    poetry add "prefect>=2.0b"
    ?
    Joshua Greenhalgh

    Joshua Greenhalgh

    2 months ago
    ==2.0b1
    trying without the pin
    same error
    hmmm - if I use pip it works 😞
    Khuyen Tran

    Khuyen Tran

    2 months ago
    yeah I often got problems when using poetry on an M1. Let me see if I can reproduce your error
    Joshua Greenhalgh

    Joshua Greenhalgh

    2 months ago
    Khuyen Tran

    Khuyen Tran

    2 months ago
    I was able to installed correct with poetry when running this command:
    poetry add "prefect>=2.0b"
    I’m using an M1
    Have you tried to create a new environment then install Prefect 2.0 with poetry to see if it works?
    Joshua Greenhalgh

    Joshua Greenhalgh

    2 months ago
    Hey - have tried the above with no luck - will try to make a repro to see if its purely a me issue!