Thread
#prefect-community
    Madison Schott

    Madison Schott

    6 months ago
    Hi all, how do I upgrade to the latest version of dbt within my Prefect flow? I am running it on a Docker container
    Running with dbt=0.20.0
    10:10:25
    INFO
    DbtShellTask
    Encountered an error while reading the project:
    10:10:25
    INFO
    DbtShellTask
      ERROR: Runtime Error
    10:10:25
    INFO
    DbtShellTask
      This version of dbt is not supported with the 'winc' package.
    10:10:25
    INFO
    DbtShellTask
        Installed version of dbt: =0.20.0
    10:10:25
    INFO
    DbtShellTask
        Required version of dbt for 'winc': ['>=1.0.0']
    Kevin Kho

    Kevin Kho

    6 months ago
    You really intend to upgrade mid Flow rather than in the Docker container? What storage are you using? Because Docker storage can easily do this. But I guess you can do this inside a task
    Note it won’t work for DaskExecutor
    Madison Schott

    Madison Schott

    6 months ago
    I'm using Docker storage
    No I would like to upgrade in the Dcker container just not sure how
    wait nvm
    this was a dumb question lol
    Kevin Kho

    Kevin Kho

    6 months ago
    All good 😆. you good now?
    Madison Schott

    Madison Schott

    6 months ago
    haha yes
    thanks!
    Anna Geller

    Anna Geller

    6 months ago
    Welcome back, @Madison Schott!