Thread
#prefect-community
    d

    Dylan

    5 months ago
    Hey when I try to toggle on a schedule I get an error message in the UI back from GraphQL, this is on a cloud backend with a K8's agent running on EKS
    Anna Geller

    Anna Geller

    5 months ago
    Do you get this from the UI or interactive API? I just tried that in the UI from the flow page and it seemed to work - the type of agent shouldn't be relevant here
    d

    Dylan

    5 months ago
    UI
    I don’t see an actionable or descriptive error anywhere I can action on
    I do see warnings that there’s no agent looking for the flow’s labels, so I’m modifying our agent label params to take care of that. Could just be an edge case being handled a little weird.
    Anna Geller

    Anna Geller

    5 months ago
    if this is some UI issue, can you send some screenshots of what you see? alternatively, you could directly open a GitHub issue in the UI repo https://github.com/PrefectHQ/ui
    Kevin Kho

    Kevin Kho

    5 months ago
    I think the actual thing here is you can’t toggle schedules right? When you go to the schedules tab of the Flow, what do you see?
    d

    Dylan

    5 months ago
    inspect element -> networking tab, then lots of graphql stuff including the message:
    [{
        "data": {
            "set_schedule_active": {
                "success": false,
                "__typename": "success_payload"
            }
        }
    }]
    But there’s no stack trace or error since that’s kinda how Graphql does things
    There’s a lot more graphql data in the browser I can send over if you want
    Kevin Kho

    Kevin Kho

    5 months ago
    I mean if you go to the Flow page and then click Settings and then Schedule
    d

    Dylan

    5 months ago
    Oh, I get the same
    Kevin Kho

    Kevin Kho

    5 months ago
    I mean I want to see the configured schedules to see if they look right
    d

    Dylan

    5 months ago
    There wasn’t one. I created one and the toggle works now.
    Seems like a bit of a gap but nothing that can’t be worked around with user behavior
    Kevin Kho

    Kevin Kho

    5 months ago
    Oh so there was just nothing to toggle?
    d

    Dylan

    5 months ago
    Yeah basically, no schedule created yet, so when I toggled it on the UI threw an error but wasn’t clear that it was bc I didn’t have a schedule yet.
    Makes sense, but just a bit of a gap.
    Kevin Kho

    Kevin Kho

    5 months ago
    Yeah I think that’s worth filing an issue in the UI repo. A message would be helpful, even if just a message to check if you have a schedule
    d

    Dylan

    5 months ago
    100%
    will do
    Kevin Kho

    Kevin Kho

    5 months ago
    Thank you!