when using prefect deployment build in the cli `--...
# prefect-community
n
when using prefect deployment build in the cli
--params='{"question": "ultimate", "answer": 42}'
Returns
Copy code
+- Error ---------------------------------------------------------------------+
| Got unexpected extra arguments (ultimate, answer: 42}')                     |
+-----------------------------------------------------------------------------+
The --param is working, but I've tried many different combinations of --params without success. Is it possible to provide a working example or see if anything has changed since it's not working?
1
j
That looks correct. Was it working earlier, Nic? What does
prefect version
show?
n
I haven't tried it before, but currently, it's not working
Copy code
Version:             2.6.4
API version:         0.8.2
Python version:      3.10.6
Git commit:          51e92dda
Built:               Thu, Oct 20, 2022 3:11 PM
OS/Arch:             win32/AMD64
Profile:             default
Server type:         cloud
🙏 1
j
I just tested with 2.6.5 and it works okay for me. Maybe it’s an issue with how the windows command line program deals with quotes: https://superuser.com/questions/324278/how-to-make-windows-command-prompt-treat-single-quote-as-though-it-is-a-double-q
n
I've tried a few different quoting 'situations' and am left with errors always, I'll continue testing tomorrow and dot down everything that doesn't work and report back
Can't get it working with the standard windows CMD or powershell. Are you running windows too, or somebody in the team running windows and has it working?
j
I don’t - but I think it’s a matter of escaping the quotes - here’s a guide for PowerShell. You mentioned earlier that the
param
flag works. Does that work for you to input your params? Alternatively, the Python deployment method might be an option.
n
I've set up a CI/CD pipeline that's integrated with a fair bit of systems at this point so changing to the python deploy would be an option, but one I'd like to avoid. We could use the param flag, but was hoping to have params working so inputting multiple parameters would be easier for our data science team that is going to use the pipeline. It might be the option - that or storing the deployment in .py files and running those instead of the cli script throught azure devops
j
I found this section of the power-shell docs which goes more in depth with single and double quotes: https://learn.microsoft.com/en-us/powershell/module/microsoft.powershell.core/about/about_quoting_rules?view=powershell-7
👍 1