https://prefect.io logo
#prefect-community
Title
# prefect-community
j

Josephine Douglas

05/10/2022, 5:42 PM
Hi again! I am using
create_flow_run
and
wait_for_flow_run
(see previous thread). The child flow takes a few hours to run, and in the meantime, the parent flow decides that it must have failed and reports that the whole parent flow failed. Is there a way to extend the timeout period for
wait_for_flow_run
?
k

Kevin Kho

05/10/2022, 5:44 PM
Yeah there was a PR for this in progress, let me check if it made it to version 1.2. The maximum was 12 hours
It’s in master but will probably be rolled out next version. The PR is here
j

Josephine Douglas

05/10/2022, 5:53 PM
Oh, awesome! But one q: that PR says 12 hours is the current limit. My child flow has been running for less than an hour, and the parent flow says
No heartbeat detected from the remote task; marking the run as failed.
If I go look at the child flow, it is still running. Is there another setting I should be using?
k

Kevin Kho

05/10/2022, 5:57 PM
Oh you threw me off there! One hour is not long haha. Yes there is still something you can do. Read this
6 Views