https://prefect.io logo
Title
a

Alexandru Anghel

10/10/2022, 6:06 PM
Hello, I have installed Prefect 1.4.0 on a Minikube instance using Helm. I am providing my own values.yaml file and setting the prefectConfig section to switch the backend to server. However, the graphql deployment config.toml still shows backend cloud once deployed. What am i missing here? Thanks!
1
I am thinking now that it's not supposed to work like i tried. It's there a way to switch to backend server when installing with Helm?
z

Zanie

10/10/2022, 6:11 PM
The backend should always be Server for the Helm chart? Are you using https://github.com/PrefectHQ/server/tree/master/helm/prefect-server ?
a

Alexandru Anghel

10/10/2022, 6:17 PM
@Zanie Yes, this is the chart i am using. If i run prefect config inside the graphql pod i see "backend": "cloud".
z

Zanie

10/10/2022, 6:18 PM
The backend setting only applies to the Prefect client i.e. your end user
It’s not relevant in the GraphQL server which is why it’s not modified.
Sounds like perhaps the
prefectConfig
is not being populated there as intended (you should be able to override it), but shouldn’t have any affect.
a

Alexandru Anghel

10/10/2022, 6:31 PM
Oh, ok, i understand. Indeed, it's not being populated according to what i set inside values.yaml.