g

    gertjan

    2 weeks ago
    Is it correct that when you add new parameters to a flow you need to delete the current deployment and recreate the deployment to update these in the UI? As a result, is it best practice to always delete all deployments and recreate them on launch? What happens with for example the
    description
    field? As you cannot set this via the cli?
    Michael Adkins

    Michael Adkins

    2 weeks ago
    Creating a deployment updates an existing one with the same name, so no deletion is necessary.
    Only passed fields should be updated, but this has been changed recently so I’m not sure.
    g

    gertjan

    2 weeks ago
    Hmm.. If I change the parameters, they are not updated in the UI.. (on latest versions of prefect)
    Jeff Hale

    Jeff Hale

    2 weeks ago
    Adding a few follow on questions. Are you changing parameter fields or parameter values? There was a bug where additional parameter fields were not being added if some already existed, but I thought that was fixed recently. Will have to look at the issues/PRs. Are you applying the change?
    g

    gertjan

    2 weeks ago
    I’m changing parameter fields. So imagine a flow without parameters and you update it with parameters, build and apply deployment, UI doesn’t find those parameters If you delete the deployment, build and apply deployment, UI finds those parameters
    Jeff Hale

    Jeff Hale

    2 weeks ago
    Gotcha. Yes, an issue was filed to this effect last week and I confirmed the bug. A PR that should have fixed it was merged 6 days ago and 2.3.2 was released on Tuesday, so it should work in 2.3.2. Is that the version you’re using?