If I'm getting this: ```UserWarning: Block documen...
# prefect-community
If I'm getting this:
Copy code
UserWarning: Block document has schema checksum sha256:28a9d16c2589998d5281b0496b25edd76c1a0b159095d0c7fe5eb5dc5ab62549 which does not match the schema checksum for class 'GCS'. This indicates the schema has changed and this block may not load.
Should I delete and recreate my GCS block?
when I load my GCS block in python, it seems to work just fine. And deploying using the block as storage also seems fine, since the files end up in my bucket. But when I run the deployed flow, it tries to retrieve the file from the wrong path (my local working directory from which I deployed the flow)
Copy code
Flow could not be retrieved from deployment.
Traceback (most recent call last):
  File "<frozen importlib._bootstrap_external>", line 846, in exec_module
  File "<frozen importlib._bootstrap_external>", line 982, in get_code
  File "<frozen importlib._bootstrap_external>", line 1039, in get_data
FileNotFoundError: [Errno 2] No such file or directory: '/Users/kevingrismore/Documents/simple-prefect/flows/flow.py'
I'm not sure why this would be happening since my deployment looks like this:
Copy code
from prefect.deployments import Deployment
from prefect.infrastructure import KubernetesJob
from prefect.filesystems import GCS

from flow import my_kubernetes_flow

storage = GCS.load('prefect-bucket-access')
infrastructure = KubernetesJob.load('k8s-job')

deployment = Deployment.build_from_flow(

deploying from the CLI worked just fine. I think I might need some guidance on why this is happening, and whether I need to use deployment args like
to correct it
if you have issues with this, I would recommend trying with the CLI which is much easier - check this post to learn more https://medium.com/the-prefect-blog/declarative-dataflow-deployments-with-prefect-make-ci-cd-a-breeze-fe77bdbb58d4