Thread
#prefect-community
    i

    itay livni

    2 years ago
    Hi - I ran into an error with the visualizer python 3.7.4 The
    flow
    did run correctly? any suggestions?
    Chris White

    Chris White

    2 years ago
    Hi @itay livni - could you describe the environment you ran this in and what version of Prefect you are running? That exception has an
    except Exception
    block, so I’m really surprised to see it get raised
    Also, did you provide the full traceback?
    i

    itay livni

    2 years ago
    prefect version 0.6.6
    Chris White

    Chris White

    2 years ago
    Ah there we go - the actual uncaught exception here is
    graphviz.backend.ExecutableNotFound: failed to execute ['dot', '-Tpdf', '-O', 'tmpqh15cbky'], make sure the Graphviz executables are on your systems' PATH
    In order to see your Flow visualization, you need to have Graphviz installed: http://www.graphviz.org/download/
    i’ll try to make this error more informative
    i

    itay livni

    2 years ago
    I do have it installed but I do need to make sure that it os on the 'PATH'
    Chris White

    Chris White

    2 years ago
    just in case you aren’t aware, the
    graphviz
    python package is only a python binding to the underlying
    graphviz
    software, so you need to install Graphviz linked above in addition to the python package
    i

    itay livni

    2 years ago
    Thank you I did not know that
    /home/ilivni/Downloads/node_viz.pdf
    Chris White

    Chris White

    2 years ago
    excellent!
    i

    itay livni

    2 years ago
    Thank you -- FWIW: I am migrating from aws step function.
    Chris White

    Chris White

    2 years ago
    very cool - I’d really love to hear about your experiences with that migration if you have some time
    i

    itay livni

    2 years ago
    yes. does phone work?