z

    Ziyao Wei

    2 years ago
    I cannot seem to get the Azure agent to work with either version FWIW
    Jeremiah

    Jeremiah

    2 years ago
    Sorry for the trouble @Ziyao Wei - I do know we have some folks running Prefect on Azure, so we’d need to dig deeper to understand where the issue is taking place - do you mind opening a GitHub issue with any relevant environment details?
    z

    Ziyao Wei

    2 years ago
    Sure! I’ll submit an issue
    Jeremiah

    Jeremiah

    2 years ago
    Thank you!
    z

    Ziyao Wei

    2 years ago
    I might have figured it out… Was being dumb - the error with 12.1.0 is not on the agent side but rather the server side
    So just to confirm - is the server side depend on azure-storage-blob v2.1.0?
    I might still file an issue, but will try things out locally first
    Jeremiah

    Jeremiah

    2 years ago
    I don’t expect the server to have any Azure dependencies, to be honest — even if you do figure it out, please open the issue so we can have better documentation for other folks on Azure 🙂
    z

    Ziyao Wei

    2 years ago
    I think you are right and this is an agent issue - https://github.com/PrefectHQ/prefect/issues/2318
    LMK if I am totally off!