Hello guys, I am trying to execute flow.visualize(...
# prefect-community
Hello guys, I am trying to execute flow.visualize() in a Pycharm IDE, but nothing is showing up. The code doesnt show any error, it executes until the end of the flow with Success, but the visualization doesnt show up.
Copy code
Anyone had this issue before?
Hi @Manuel Mourato! I haven't seen this before; is this happening with all flows or just a specific one?
All flows. I tried executing before the run, but no luck. I will try to execute from the cli and see if the issue remains
It's working. For some reason the error did not show up in the IDE, but running in the console, I saw
Running Firefox as root in a regular user's session is not supported :$HOME is /home/user which is owned by user.
, and indeed I was executing with a different user. Changing users solved the issue.
Very odd, I wonder why Pycharm was suppressing the error. Glad you got it worked out!
@Marvin archive “flow.visualize doesn’t show an error in Pycharm”