Thread
#prefect-community
    Will Milner

    Will Milner

    2 years ago
    I'm getting a weird error from the apollo service whenever I try and run a flow. The error I see in the logs is this
    apollo_1     | 2020-05-15T16:42:41.530Z {"message":"Cannot query field \"setFlowRunStates\" on type \"Mutation\". Did you mean \"set_flow_run_states\" or \"set_task_run_states\"?","locations":[{"line":2,"column":5}],"extensions":{"code":"GRAPHQL_VALIDATION_FAILED"}}
    
    apollo_1     | 2020-05-15T16:42:41.547Z {"message":"Unknown type \"writeRunLogsInput\". Did you mean \"write_run_logs_input\", \"write_run_log_input\", \"create_flow_input\", or \"archive_flow_input\"?","locations":[{"line":1,"column":18}],"extensions":{"code":"GRAPHQL_VALIDATION_FAILED"}}
    Not sure how I go about debugging this, any tips?
    Tyler Wanner

    Tyler Wanner

    2 years ago
    Hi Will.. Just to be clear--is that Prefect Server? If so, are you building and registering your flow from the same prefect core install/ version as the one from which you are running server?
    Jenny

    Jenny

    2 years ago
    Hi @Will Milner - can you give me a bit more info about where you're seeing this? Things that might be helpful to know are - can you confirm you're running server? What version of prefect are you? How are you running the flow (from the UI?)
    Ha! You got two sets of questions - feel free to respond to either or both.
    Will Milner

    Will Milner

    2 years ago
    This is running from prefect server, version 11.0
    running with a docker agent
    Jenny

    Jenny

    2 years ago
    Thanks - let me look into it
    Tyler Wanner

    Tyler Wanner

    2 years ago
    is it possible you registered your flow with a different install/ version of prefect?
    if so, that could explain it. otherwise, Iā€™m not sure where that casing is coming from
    Will Milner

    Will Milner

    2 years ago
    i did recently upgrade to version 11.0 today, before that i was on version 10.7, I still see this problem after re-registering my flow though
    Tyler Wanner

    Tyler Wanner

    2 years ago
    can you verify the prefect version inside of your flow is 0.11.0 as well?
    Will Milner

    Will Milner

    2 years ago
    that was the issue, I was using the improper version of prefect inside of my docker image, forgot to update the tag from the base image I was building from
    thanks for the help
    Tyler Wanner

    Tyler Wanner

    2 years ago
    ah awesome! glad we could help