https://prefect.io logo
#prefect-community
Title
# prefect-community
s

Sandeep Aggarwal

06/30/2020, 1:36 PM
Looks like agent process loops in increasing intervals to look for available flow runs, which goes up to 10 secs max. This latency can be huge for workflows that don't receive frequent requests, however should to processed without delays as & when triggered. Is there a way to override this behaviour?
z

Zachary Hughes

06/30/2020, 1:42 PM
Hi @Sandeep Aggarwal! There's no built-in way to override this behavior. If you're working in an environment with an editable install of Prefect, you could always tweak it there. If this is something you'd like to pursue further, could you open an issue on Github? That will let us socialize and potentially prioritize this change.
s

Sandeep Aggarwal

06/30/2020, 2:23 PM
Thanks for quick response @Zachary Hughes. Yes I think I can modify it as required. However, just wanted to know if there is any specific reason for keeping it this way that I should be aware of?
z

Zachary Hughes

06/30/2020, 2:43 PM
Good question! We implemented it this way because Prefect doesn't guarantee sub-minute accuracy on schedules, and setting up a faux-exponential backoff with a maximum interval of 10s helped us take some polling pressure off of our API.
s

Sandeep Aggarwal

06/30/2020, 3:21 PM
Makes sense. Will keep that in mind while I make the changes.