Hi,My flow run failed when started from the Prefec...
# prefect-community
Hi,My flow run failed when started from the Prefect UI. Logs say :"AttributeError: 'Flow' object has no attribute 'slugs' ". After finding the solution in the slack channel i tried to get my current prefect version. My current prefect version is "0+unknown". I tried to force reinstall prefect version again but still getting the same unknown version.What does it mean.
Hi @mithalee mohapatra, just to clarify: when you run
pip show prefect
, you're getting back something that looks like:
Copy code
Name: prefect
Version: 0+unknown
Summary: The Prefect Core automation and scheduling engine.
Home-page: <https://www.github.com/PrefectHQ/prefect>
Author: Prefect Technologies, Inc
, correct?
How method did you use to install prefect (e.g. pip, conda, etc...)?
Here is what i get :
Hmmm, that's odd. This was pip install from pypi?
This is the error from the Prefect UI logs:
Yes pip install from pypi.
So ignoring the weird unknown version bit, the error you're seeing is because the environment your flow is running in doesn't match the environment the flow was built in. Slugs were added to
objects in version 0.12.1. It looks like your flow runner must be running at least 0.12.1, while your flow was built with 0.11.4.
Not knowing what your agent/environment setup is, the general recommendation is to match python and prefect versions between the execution and registration environments.
Thank you Jim. So a reinstall of prefect should help.
Yeah, that'd be the first thing I'd try.
👍 1