https://prefect.io logo
#prefect-community
Title
# prefect-community
b

bral

08/10/2020, 3:47 PM
Good evening ! I faced with problem : on same server started prefect , and local agent. If i try go to http//serverip:8080 from remote machine i do not see any flow, because ui trying to connect to httplocalhost4200/graphql. Which options i should change ?
r

Roy

08/10/2020, 3:51 PM
I had this problem too. I solved this by not only port-forwarding port 8080, but also 4200. It seems that your browser needs to be able to access it as well.
k

Kyle Moon-Wright

08/10/2020, 3:59 PM
Glad you were able to solve that @Roy. @bral To change these settings, I'd recommend creating a user configuration with a config.toml file, you can read about that here.
b

bral

08/10/2020, 4:03 PM
@Roy you changed docker-compose.yml ? In which service you added additional port forwarding ?
@Kyle Moon-Wright thanks! If it possible, can you send example of config file? In link posted by you example only for [api] section.
k

Kyle Moon-Wright

08/10/2020, 4:15 PM
Of course, here's an example directly from the Prefect repository. Note that this is the full list of configurations and it's format - so you should only use what you need.
👍 1
b

bral

08/10/2020, 9:29 PM
@Kyle Moon-Wright thank you for full config file! I tried to change all settings concerning url by iterarion. But still in ui the connecting api has not changed. And when trying to access from remote machine from the local network the error is same.
Meanwhile from local machine:
k

Kyle Moon-Wright

08/10/2020, 10:03 PM
Hmm, I'd recommend checking out this article on setting up Server on a remote machine. Though this tutorial deploys on GCP and uses an older version of the UI, many of the configurations will be relevant for setup. I'm certainly not a networking expert, but we may need to define the endpoint on the remote machine to ensure it's communicating with the running backend services.
b

bral

08/10/2020, 10:50 PM
@Kyle Moon-Wright thank you for article ! Problem solved! Also you can connect using new feature of ui: there is connecting string in /home page.
k

Kyle Moon-Wright

08/10/2020, 11:00 PM
Aha, nice! Thanks for reminding me of that. 👍