Thread
#prefect-community
    Vikram Iyer

    Vikram Iyer

    2 years ago
    Hi, I am getting the below error all of a sudden. The setup had been working fine for me before.
    ad-agent_1              |   File "/usr/local/lib/python3.7/site-packages/requests/models.py", line 941, in raise_for_status
    ad-agent_1              |     raise HTTPError(http_error_msg, response=self)
    ad-agent_1              | requests.exceptions.HTTPError: 400 Client Error: Bad Request for url: <http://ad-prefect-apollo:4200/>
    The env variable on the
    agent
    container is:
    PREFECT__SERVER__ENDPOINT: <http://ad-prefect-apollo:4200>
    I am running all the required services inside docker containers using docker-compose file. Can anyone check and help out?
    Kyle Moon-Wright

    Kyle Moon-Wright

    2 years ago
    Hey @Vikram Iyer, Have you set your Apollo service endpoint to an accessible address? Typically we'd recommend setting the Apollo endpoint with a config.toml like this:
    [server]
    endpoint = "${server.host}:${server.port}"
    And setup the agent to an address with the
    agent_address
    kwarg when starting the agent. Though I may be misunderstanding your setup.
    Vikram Iyer

    Vikram Iyer

    2 years ago
    @Kyle Moon-Wright I am thinking the newer update i.e. 0.13.4 has created some issues? When I changed back to the old version i.e. 0.12.4, it worked.
    Kyle Moon-Wright

    Kyle Moon-Wright

    2 years ago
    Ah, gotcha. Yep there were definitely some changes to Server with the latest update to
    0.13.x
    . You may notice that server and the UI have separate repos now on GitHub with some upgrades from the previous version.
    I'd recommend opening up an issue on the Server repo if you keep getting blocked by the upgrade and can't get the configuration down.
    Vikram Iyer

    Vikram Iyer

    2 years ago
    Sure. I will do that. I am unblocked for now but seems like I should raise an issue before something else breaks.
    Also, we wont be retiring 0.12.4 anytime soon right?
    Kyle Moon-Wright

    Kyle Moon-Wright

    2 years ago
    Definitely not! Just an adjustment to Prefect Server to make updates and maintenance easier - check out this announcement from Jeremiah not long ago.