h

    Howard Cornwell

    2 years ago
    Hi all. Is it possible to migrate from 0.11.5 to 0.13.3? I get the following error, so I assume it’s not possible?
    graphql_1   |                                                                                  
    graphql_1   | Running Alembic migrations...                                                    
    graphql_1   | INFO  [alembic.runtime.migration] Context impl PostgresqlImpl.
    graphql_1   | INFO  [alembic.runtime.migration] Will assume transactional DDL.
    graphql_1   |                                                                                  
    graphql_1   | Could not upgrade the database!
    graphql_1   | Error: Can't locate revision identified by '7e65dadba625'
    nicholas

    nicholas

    2 years ago
    Hi @Howard Cornwell - upgrading Server between those two versions isn’t possible but the rest of Core should work just fine. The reason is that 0.13.0 introduced a complete overhaul of Server with a host of new features and a shared code base with Prefect Cloud. My recommendation would be to create a new Server instance on 0.13.3 and re-register your flows there.
    h

    Howard Cornwell

    2 years ago
    Thanks for the response, appreciated 🙂
    l

    Luke

    2 years ago
    Hi @Howard Cornwell I received the same error as nicholas. How do I create a new Server instance on 0.13.3?
    nicholas

    nicholas

    2 years ago
    Hi @Luke - you'll need to upgrade your version of Prefect (
    pip install prefect --upgrade
    ) and re-run
    prefect server start
    l

    Luke

    2 years ago
    thanks, nicholas. hmm...I have 0.13.3 installed but am still getting that error after re-running
    prefect server start
    nicholas

    nicholas

    2 years ago
    It seems you're trying to run the new Server instance on an existing Server database - since the old DB is incompatible with the new, you'll need to remove any persistent volumes to make that happen.
    l

    Luke

    2 years ago
    that worked. Thank you!