s

    Sven Teresniak

    2 years ago
    v0.13.5: The UI is not working because UI (or my browser?) cannot connect to http://localhost:4200/graphql - which is corret because apollo is running in a container in k8s. I have a service with an open port 4200 for apollo. So I set
    PREFECT_SERVER__GRAPHQL_URL
    to the FQDN of my service with port 4200 and everything. With that ENV the UI worked perfect with v0.12.5. But the new Prefect is completely ignoring that ENV.
    When I see the home screen in the UI I can put in my graphql URL and the UI (my browser) will perfectly connect to apollo. The UI is working. But how can I set this URL permanently (using ENV for example?)
    nicholas

    nicholas

    2 years ago
    Hi @Sven Teresniak - this was a breaking change with the new version of Server/UI. We have a ticket open to allow this to be set permanently, which also details why that’s been changed. One option you have to change it permanently is to run the UI in development mode and change the
    .env
    file to match your setup.
    s

    Sven Teresniak

    2 years ago
    Thanks!