Jonas Bernhard

10/21/2020, 3:43 PM
Hi, I just saw this issue and it sounds an awful lot like the reason why my flow is failing. However, I did not understand in what way it was resolved. Is adding
"<|>": "false"
currently the way to go? Other than that, we currently use the Helm charts from which work pretty great so far. Is there a way to assist to push that forward since "official" Helm charts would be pretty awesome (however I don't have a lot of experience with Helm).


10/21/2020, 4:05 PM
Hey @Jonas Bernhard (for your first question) that looks like a mistype I don’t think that PR should have closed that issue! I believe setting that safe-to-evict policy is the way to go
As for the helm chart I think the PR has been slightly forgotten @Shaun Cutts is there anything else that needs to be done for it? I’m down to push it through sometime soon

Joseph Haaga

10/21/2020, 5:48 PM
FWIW i’m new to this initiative, but I’m not sure the defaults are entirely finished; we get the following error related to the UI
being enabled, but no rules/hosts being declared
Copy code
$ git clone <>

$ git checkout helm-chart

$ cd helm

$ helm install --namespace prefect prefect-server ./prefect-server

dependencies.go:260: Warning: ImportValues missing table: "exports" is not a table
Error: failed to create resource: Ingress.extensions "prefect-server-ui" is invalid: spec: Invalid value: []networking.IngressRule(nil): either `backend` or `rules` must be specified
so the above was resolved by altering ui.ingress in values.yaml:
Copy code
      - host: ""
          - "/"
but I still get errors when running
helm install
. It looks like I get the same error when I run `helm lint`; is anyone else seeing this?
Copy code
$ helm lint

==> Linting .
[INFO] Chart.yaml: icon is recommended
[ERROR] templates/: template: prefect-server/templates/ui/ingress.yaml:37:30: executing "prefect-server/templates/ui/ingress.yaml" at <include "ui.fullname" .>: error calling include: template: prefect-server/templates/ui/_helpers.tpl:6:19: executing "ui.fullname" at <include "prefect-server.fullname" .>: error calling include: template: prefect-server/templates/_helpers.tpl:15:14: executing "prefect-server.fullname" at <.Values.fullnameOverride>: can't evaluate field Values in type string

Error: 1 chart(s) linted, 1 chart(s) failed

Jonas Bernhard

10/26/2020, 9:28 AM
@Joseph Haaga also had the first error and simply disabled the UI ingress. The second error did not appear during my install, however.

Joseph Haaga

10/26/2020, 4:02 PM
@Jonas Bernhard which version of Helm are you running? I got this error on v3.3.4

Jonas Bernhard

10/26/2020, 4:02 PM
I'm also on
I guess the error comes from a bug in the template for the ingress values you changed. When I changed the resources in
the templating also didn't quite work correctly

Joseph Haaga

10/26/2020, 4:11 PM
ahh that makes sense! Got any recommendations for providing access to the UI? I figured an Ingress was the appropriate way to do that, but I’m fairly new to this stuff; otherwise I can continue playing with the appropriate syntax for declaring a UI ingress