Aiden Price

    Aiden Price

    1 year ago
    Hi again folks, I've deployed server with the new helm chart and everything works when I port-forward. Now I've set up some Kubernetes ingresses to expose the UI and GraphQL endpoints. The special case here is that I need to host these at a path on the domain like so
    <https://etl.mydomain.com/prefect>
    . But when I try to go to the dashboard it doesn't load, looking at Chrome's console I can see that the page is requesting all its files without my path part, e.g.
    <https://etl.mydomain.com>
    . I tried adding the env var
    PREFECT_SERVER__SERVER_UI_ENDPOINT
    as the full URL and path but it doesn't seem to have changed the behaviour. Does anyone have any advice? Thanks.
    Michael Adkins

    Michael Adkins

    1 year ago
    Hi again 🙂 I removed ingresses because we don’t have the capacity to have to support them yet and didn’t want to include the deployment of an ingress controller. Here’s a commit before I removed them if that’s helpful (but I never got a chance to test it with a custom domain) https://github.com/PrefectHQ/server/blob/fc2a5079b542e9581934d2f0c9831c5fd825f4ca/helm/prefect-server/templates/ui/ingress.yaml
    I can add a tutorial on how to setup ingresses to the docs but it’s not a top priority. I’d be excited if there was a PR from the community!
    After checking in with our team, this issue actually looks related to https://github.com/PrefectHQ/ui/pull/450 and I’m not sure it’ll be easily resolved from Helm, hmm
    Aiden Price

    Aiden Price

    1 year ago
    I see, it's definitely more complicated than I'd thought. Might have to park the URL path idea for a while and what comes of the pull request. Thank you for getting back to me again.