Thread
#prefect-community
    j

    Jonas Hanfland

    1 year ago
    Hi guys, I am having an issue with one of my flows not terminating due to a single mapped task ("mapped child 1") being stuck in pending. When checking the logs for that mapped task, I found what seems to be an internal server error (see thread). I think there have been one or two flows in the past, with the same kind of issue (one mapped task stuck in pending), but I am not able to retrieve their logs so I can't be sure. For the old runs, subsquent re-runs finished successfully, but this time the re-run seems to run into the same issue (+ same exception in logs). Is that exception the cause for the problem? Is the issue on prefect's side or on mine?
    Exception:
    Failed to retrieve task state with error: ClientError([{'path': ['get_or_create_task_run'], 'message': 'Invalid ID', 'extensions': {'code': 'INTERNAL_SERVER_ERROR'}}])
    Traceback (most recent call last):
      File "/usr/local/lib/python3.8/site-packages/prefect/engine/cloud/task_runner.py", line 190, in initialize_run
        task_run_info = self.client.get_task_run_info(
      File "/usr/local/lib/python3.8/site-packages/prefect/client/client.py", line 1227, in get_task_run_info
        result = self.graphql(mutation)  # type: Any
      File "/usr/local/lib/python3.8/site-packages/prefect/client/client.py", line 294, in graphql
        raise ClientError(result["errors"])
    prefect.utilities.exceptions.ClientError: [{'path': ['get_or_create_task_run'], 'message': 'Invalid ID', 'extensions': {'code': 'INTERNAL_SERVER_ERROR'}}]
    Chris White

    Chris White

    1 year ago
    Hm that’s very odd - does this happen every time you run your flow or only sometimes?
    j

    Jonas Hanfland

    1 year ago
    I think it has now become a re-occuring issue, since the last 2 re-runs failed the same way