c

    Christian

    1 year ago
    Hi all. I'm trying to implement a docker storage flow on a prefect server instance on a workstation in our network. I build a custom docker base image and push it to docker.io. However, I get an error registering my flow... Not sure where this might originate?
    requests.exceptions.HTTPError: 404 Client Error: Not Found for url: <http+docker://localhost/v1.40/images/create?tag=0.13.19-python3.9&fromImage=prefecthq%2Fprefect>
    more trace ...
    File "/Users/werner-ch/.pyenv/versions/3.9.0/envs/dataflow/lib/python3.9/site-packages/docker/errors.py", line 31, in create_api_error_from_http_exception
        raise cls(e, response=response, explanation=explanation)
    docker.errors.NotFound: 404 Client Error for <http+docker://localhost/v1.40/images/create?tag=0.13.19-python3.9&fromImage=prefecthq%2Fprefect>: Not Found ("manifest for prefecthq/prefect:0.13.19-python3.9 not found: manifest unknown: manifest unknown")
    Would anyone know where I should start digging? My base image is: https://hub.docker.com/r/cwerner/dataflow
    Michael Adkins

    Michael Adkins

    1 year ago
    We may not be publishing a python 3.9 docker image yet as it’s our extra extensions don’t support python 3.9.
    I’d recommend using 3.8 until 3.9 is more mature
    c

    Christian

    1 year ago
    ah ok. will switch to 3.8 - no problem
    however, the localhost has me confused in the message... is the ok?
    Michael Adkins

    Michael Adkins

    1 year ago
    I believe that is just the docker client talking to the local docker “server”
    If you have issues with 3.8, let me know and we can work through it
    c

    Christian

    1 year ago
    ok, cool... thanks! will report back to this thread if this fixed it
    Ok, that was it! 🎉 Thanks again...