12/19/2020, 2:18 PM
Hi ! I am running the following simple testing flow:
Copy code
import prefect
from prefect import task, Flow, Parameter, flatten, unmapped
from prefect.executors import DaskExecutor
from prefect.run_configs import LocalRun

def test_parallel(a):

with Flow("filtering-counting",run_config=LocalRun(), executor = DaskExecutor(address='<tcp://>')) as flow:
   all_data = Parameter('all_data',default = list(range(10)))
   mapped = 
I have updated to the new version of prefect and I get
prefect.CloudFlowRunner | Flow run RUNNING: terminal tasks are incomplete.
In the setup with the previous version of prefect I was not getting the error. I still get the error even if
I have being going through the docs but I still cannot understand where the error is coming from. Thanks!

Chris White

12/19/2020, 7:00 PM
Hi simone; the log you have provided is not an error and can occur during normal operation, so we’ll need more information to get to the bottom of your issue


12/20/2020, 8:15 AM
Hi! The processing seems to start but keep running, none of the task is completed (not even the parameter one) but beside the log I posted in the message above I don't get any error. I am running a DaskExecutor on a HPC on prem. The agent is started `prefect agent local start --show-flow-logs`inside the code folder . The only other message I have not seen before is this output from docker
Copy code
INFO[2020-12-19T12:44:57.513535530+01:00] Firewalld: interface br-92be81a89969 already part of docker zone, returning
INFO[0000] Firewalld: docker zone already exists, returning .
I am running prefect 0.14 Thanks a lot for looking into this! Please let me know which other type of info you need to better understand the issue
@Chris White After a while I got back to the issue and figure out that the flow is processed correctly when
Copy code
run_config=LocalRun(), executor = DaskExecutor(address='<tcp://>')
are removed from the Flow definition. FYI: Just to make sure that the issue is not cause by the flow I run one of prefect examples and behave the same as my testing flow. Where should I start to troubleshoot? Do you thing is something related to the agent? Thanks for the help!
Ok I found the solution, I needed to start the agent with a different tcp address for the --api flag. Thanks a lot!
💯 1