Matthew Blau

01/04/2021, 2:24 PM
Hello all, I am getting this message on my prefect server set up. I had changed the config.toml to point to the correct IP address modeled after this example. what am I doing wrong?

Kyle Moon-Wright

01/04/2021, 8:29 PM
Hey @Matthew Blau, Tough to say exactly what issue you’re encountering, however I would recommend using as little of the linked config.toml file as possible to avoid complexity (configuring only what you need!), as Prefect Server will auto-populate the values it requires. Also, some sanity checks: 1 - Did you call
prefect backend server
prefect server start
? 2 - Have you set the appropriate environment variables to point to your Server deployment? For the UI this means setting 
 as either an environment variable (
) or in your machine’s 
Copy code
# ~/.prefect/config.toml

  apollo_url="your endpoint:4200/graphql"
You can read more about the different configuration options for Prefect Server in the Prefect configuration docs.

Matthew Blau

01/04/2021, 9:31 PM
Hey @Kyle Moon-Wright I had set the backend to server prior to server start. We have a different IP that localhost that everything runs on; which is what I had swapped out in each part of the reference config.toml. I will be back tomorrow with more information as I have ran out of time today to work on this for the day.
👍 1

Arnaud Fombellida

01/05/2021, 12:15 PM
Hey @Kyle Moon-Wright I'm encountering the same issue. See below for an image of the request sent by the UI which fails. The apollo server seems to be refusing requests. From the machine that hosts prefect, I tried running
prefect server create-tenant --name default --slug default
which fails with the following error:
requests.exceptions.ConnectionError: HTTPConnectionPool(host='', port=4200): Max retries exceeded with url: /graphql (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f4b14a1dc70>: Failed to establish a new connection: [Errno 111] Connection refused'))
The apollo server is running (according to docker ps) and listening to port 4200. However, there are no logs showing up for it after starting prefect (not sure if that's normal).