Thread
#prefect-community
    Fina Silva-Santisteban

    Fina Silva-Santisteban

    1 year ago
    Hi everyone, I’ve tried registering a prefect flow using docker storage and ECS run config today and received a
    pip
    and
    python 2.7
    error? (pls see screenshots) The dockerfile I’m using for the docker storage (
    flow.storage = Docker(dockerfile="Dockerfile", …)
    looks like this
    FROM python:3.9
    WORKDIR /app
    COPY . .
    ENV PYTHONPATH=$PYTHONPATH:`pwd`
    FROM <http://gcr.io/google-appengine/python|gcr.io/google-appengine/python>
    RUN apt-get update
    RUN apt-get install poppler-utils -y
    I’ve set the python version to 3.9 in the dockerfile, why doesn’t it use that?
    Chris White

    Chris White

    1 year ago
    Hi @Fina Silva-Santisteban! I believe this is happening because of your second
    FROM
    statement:
    FROM <http://gcr.io/google-appengine/python|gcr.io/google-appengine/python>
    this image most likely has python2.7 as the default
    Fina Silva-Santisteban

    Fina Silva-Santisteban

    1 year ago
    Thanks so much @Chris White! Yes that makes sense! We’ve checked the docs and it says exactly that:
    # Use -p python3 or -p python3.7 to select python version. Default is version 2.
    https://github.com/GoogleCloudPlatform/python-runtime