Thread
#prefect-community
    wiretrack

    wiretrack

    1 year ago
    Hey guys, having a hard time registering the
    kubernetes agent
    keep getting
    [Errno -2] Name or service not known
    . Tried every variation for apollo: prefect-apollo-service(my svc name),
    <http://prefect-apollo-service:4200/graphql>
    , the
    https
    address, can’t make it to work. any ideas on what I should be doing to get the agent to talk to apollo? If I remove the
    http
    I get a different error:
    1 No connection adapters were found for 'prefect-apollo-service:4200/graphql'
    m

    Mariia Kerimova

    1 year ago
    Hello! Just to clarify, do you deploy agent on the same cluster? I believe you need to change the url to
    <http://prefect-apollo-service>.<paste the namespace where apollo service lives>:4200/graphql
    . For example if apollo service in default namespace:
    <http://prefect-apollo-service.default:4200/graphql>
    . Let me know if it will not work for you.
    wiretrack

    wiretrack

    1 year ago
    Hi @Mariia Kerimova thanks a lot! I managed to make it work by changing the
    PREFECT_SERVER_HASURA_HOST
    , I was using something like
    <http://hasura-service:3000>
    and it should have been just
    hasura-service
    don’t really know why, but that’s what was happening. Big thanks to @Michael Adkins that helped a lot on the debugging. More details in this issue in Github: https://github.com/PrefectHQ/prefect/issues/4738 Anyways, good point about the namespace, I had tried that, but could easily be a miss if someone is using a custom namespace, thanks!
    m

    Mariia Kerimova

    1 year ago
    I'm glad your issue was solved! 🙌