Thread
#prefect-community
    Michael Hadorn

    Michael Hadorn

    1 year ago
    Hi there I'm facing again this error with the current version 0.15.5:
    requests.exceptions.ConnectionError: HTTPConnectionPool(host='host.docker.internal', port=4200): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f43cca967c0>: Failed to establish a new connection: [Errno 111] Connection refused'))
    First time i got this was in 0.14.19, but not in 0.15.4.
    I'm using: • Docker version 20.10.8, build 3967b7d • docker-compose version 1.29.1, build c34c88b2 I know there were many attempts to fix this (in docker/moby/prefect). I already looked at these: • https://github.com/PrefectHQ/server/issues/25 https://github.com/PrefectHQ/prefect/pull/4809 https://github.com/PrefectHQ/prefect/pull/4714 Could you help please? 🙂
    This error appears in the docker agent, where i wanna access the graphql on the same server
    Kevin Kho

    Kevin Kho

    1 year ago
    Hey @Michael Hadorn, I think this is related to some breaking changes with 0.15.5. Check here . You might need the 
    --expose
     flag to enable remote connections. Server would also need to be upgraded to 2021.09.02. I am not sure if this is the issue though since it’s on the same machine. Let me know your thoughts? There is a US holiday so I’d have to ask the team tomorrow if this is not it.
    Michael Hadorn

    Michael Hadorn

    1 year ago
    Oh well. Sorry for not reading exactly... 😅 Will test it tomorrow and update here. Thanks for your help.
    Kevin Kho

    Kevin Kho

    1 year ago
    No worries! It’s a new release
    Michael Hadorn

    Michael Hadorn

    1 year ago
    It will work with the flag
    --expose
    . I guess we got an error because we register (docker) flows in a own (docker) flow. This seems to also use the exposed flags, because the flow runs in a own docker container (own network?).
    Anyway much thanks for your help!
    @Kevin Kho Is there a way to access from the flow (run by the docker agent) directly the graphql on the server (not exposed)? We need this to register flows with flows. Without the expose flag the graphql (apollo) port is binded to localhost only. With host.docker.internal I access via the IP of my host (in the docker network). That will not work, without expose i guess. Or did i miss something?
    Kevin Kho

    Kevin Kho

    1 year ago
    I don’t think you missed anything here. I think you do need it exposed