Thread
#prefect-community
    Maurits de Ruiter

    Maurits de Ruiter

    10 months ago
    Hi everyone, we just updated from 0.15.4 to 0.15.9 and suddenly our flows are failing on a specific line of code. Every instance of
    if status in ['SUCCEEDED', 'FAILED']:
    fails with the following error:
    TypeError: 'sequence' not supported between instances of 'str' and 'tuple'
    If we log the type of string and array, it returns their types correctly.
    It also fails with the same kind of error on:
    if 'Contents' not in page:
    Where page is a dict. The error here is:
    TypeError: 'dict' not supported between instances of 'str' and 'dict'
    j

    Jake Kaplan

    10 months ago
    Hi Maurits, do you have a minimum reproducible example that works with 0.15.4 and fails with 0.15.9?
    Maurits de Ruiter

    Maurits de Ruiter

    10 months ago
    Hi Jake, Well, a test was working locally on my pc, so I looked at the differences with the ECS Agent and it seems the Python-version was the problem. Locally I was running 3.8 and the ECS task used the prefecthq/prefect:0.15.9-python3.9 image. After changing this to the python3.8 tag, it was working again.
    j

    Jake Kaplan

    10 months ago
    I am not sure off of the top of my head a change between python3.8 and 3.9 that would cause this type of error (prefect should support both). I'll try to see if I can find something. I'm glad you were able to resolve your issue for now!
    Maurits de Ruiter

    Maurits de Ruiter

    10 months ago
    Yeah, it’s kinda strange, because I updated locally as well, to test this issue. Locally it’s still working as expected, no sudden errors
    Okay, so I just ran a flow locally with Python3.9, which worked fine. Then I registered it with an ECSRun on a Python3.8 container, and it failed again, now with this error: SystemError(‘unknown opcode’)
    It seems to be a problem when you work locally in another Python version then the environment where the flow eventually runs